Airjamz: Compatible Devices

Most Newer iOS & Android Phones & Tablets Are Supported!

  • iPad Mini (or Later)
  • iOS 8.12+ iPad 3 (or later)
  • iOS 8.12+ iPhone (4S or later)
  • iOS 8.12+ iPod touch (5th Gen or later)
  • iOS 8.12+
  • Android Devices with Bluetooth LE Running at least Android 5.1.1
  • Amazon Fire (5th Generation)
  • Amazon Fire HD 10 (5th Generation)
  • Amazon Fire HD 8 (6th Generation)
Powered by Zendesk