I can’t connect to my Android via Bluetooth!

1) Ensure Bluetooth on your device is enabled.

2) Make sure you are connecting through the Jamstik+ App. Download it on the Google Play Store. Get the apps.

3) Your phone/tablet may not meet the requirements to run jamstik+. Check here to see if your device meets the system requirements.

 

Disclaimer:

If you do choose to purchase a Jamstik+ with a non-verified device from our list, mileage may vary. We do have a 30 day return policy if you choose to test with your device, and we would appreciate if you shared your results with untested devices should you go this route. To do so, please submit us a Jamstik+ Android Usage Survey.

 

Note:

Jamstik+ firmware version must be above version 4.023 for connecting to Android over Bluetooth. If you were an original Kickstarter Backer or have a unit older than a year that has not been connected yet, you may have old factory firmware. You can connect the Jamstik+ to your Android device using a micro USB cable to upgrade your Firmware Version.

 

Powered by Zendesk