Q: Will my Android with version 6.0 work with Jamstik+?

A: Some version 6.0 devices will connect to the jamstik+ over Bluetooth. Please do research on your devices to see if you are compatible and for manufacturer/carrier roll-out dates. Performance may vary.

Will your phone receive 6.0.1? Check this list to be sure.

Check if we support your Android device here.

 

Powered by Zendesk