What iPhone, iPad, and Mac Models Are Compatible with the Puc+?

The following iOS devices are compatible but must be updated to iOS 8.2+; iPad Mini, iPad 3 or newer, iPad Air, iPad Air 2, iPhone 5 or newer. Compatible Macs have to have OS X 10.10 Yosemite installed and support Bluetooth LE (4.0) connectivity. To check your Mac’s compatibility follow the steps outlined in this video

Powered by Zendesk